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1
Introduction to the manual

Contents of this chapter
This chapter contains information on the applicability, compatibility, target audience and 
the purpose of the manual. It also describes the contents of the manual.

Applicability
This manual applies to the Drive composer PC tool available in two different versions:
• Drive composer entry, DCET-01
• Drive composer pro, DCPT-01 (code: 3AUA0000108087).

Drive composer entry can be downloaded for free by navigating to www.abb.com/drives 
and selecting Drive PC Tools. Drive composer pro includes all features and is available 
through ABB sales channels. Both versions require registration.

Note: The features available only with Drive composer pro are indicated with (pro).

Target audience
The reader is expected to be an automation engineering professional or an electrician and 
familiar with drive products and the concepts regarding their commissioning and operation, 
including the parameter system of ABB drives. Also a basic knowledge of Microsoft 
Windows operating system is needed.

Purpose of the manual
This manual describes the Drive composer PC tool and instructs how to use it in the 
commissioning and maintenance of the ABB drives.
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Contents
The manual consists of the following chapters:
• Introduction to the manual provides information on the applicability, compatibility, 

target audience and the purpose of the manual.
• Overview of Drive composer briefly lists the main features of the Drive composer 

software and instructs how and where it can be run, and how to get help and additional 
information.

• Installation and uninstallation of Drive composer describes how to install and uninstall 
the Drive composer software.

• Connections describes how to make a connection with a drive through USB or 
Ethernet.

• Main user interface components describes the main user interface components of the 
Drive composer PC tool, including the menus.

• Parameter window describes how to use the parameter window.
• Monitor window describes how to use the monitor window.
• Workspace handling describes the workspace functionality.
• Event logger describes how to use the event logger.
• Diagnostics describes how to troubleshoot a drive with the Support package button 

of Drive composer and the data logger included in the drive.
• Control diagrams (pro) describes how to use the control diagrams.
• FSO configuration contains the configuration procedure of the FSO-12 and FSO-21 

safety functions with Drive composer pro and provides an example of how to configure 
the optional FSO-12 and FSO-21 safety functions module.

• Other functions describes common functions that are not associated with any view or 
window. For example, instructions on creating backup of a drive, using the Drive 
parameter conversion tool, using the PSL2 data viewer, and so on. 
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Terms and abbreviations used in this manual
Term or abbreviation Explanation

Alarm limit of monitoring You can set a low or high alarm limit for monitoring. Color(s) of the signal(s) 
change(s) on the monitoring graph area if the limit is reached.

Assistant Provides predefined steps for setting the parameters of the drive. For example, 
the basic start-up assistant.

Assistant control panel Control panel with an USB connector enabling a PC tool connection for 
common architecture drives. Assistant control panel is a generic name for 
ACS-AP-I and ACS-AP-S panels.

Autoscaling Y-axis scaling is set automatically when this button is enabled. User-defined y-
axis limits are then disabled.
Note: Zooming is not possible in the Autoscaling mode.

Backup Backup of the drive. Backup can be created with Drive composer or with 
control panel*. The Drive composer backup file (.dcparamsbak) includes all 
parameters, adaptive program and user sets.
With a backup file from an old drive, you can quickly configure a new drive or 
restore configuration after firmware update.
Note: Backup file does not include firmware, IEC program or license.
* Refer to control panels user’s manual.

Basic control panel Control panel with limited basic functionality used with common architecture 
drives.

Bit mask of monitoring You can filter bits of the Status word and monitor them individually.

Common architecture 
drives

For example, ACS880, DCS880, ACS580, ACH580, ACQ580, ACS560 and 
ACS480.

Compare parameters You can compare parameters between drives or between a drive and a file to 
find out differences.

Control diagrams Graphical presentation of the drive reference chain or other function. Shows 
online values of a parameter, switch positions and signals. Parameters can be 
modified online. Functionality is not available for all drives.

Copy/Download 
parameters

Visible parameters of a parameter window or custom parameter window are 
copied/downloaded to a drive.

Cursor tool Monitor window has a double cursor tool and the positions of cursors can be 
freely set in the monitor window. y2—y1 and x2—x1 differences are calculated.

Custom parameter 
window

You can create windows and drag drop (copy) parameters to these windows. 
You can also change parameter values in the window and save the changes for 
using in offline mode. The Filename extension for custom parameters is 
*.dccustparams.

Data file viewer In the Demo/Offline mode, the monitor window can be used as a data file 
viewer when saved monitored data (*.dcmon) or data logger data is analyzed.

Data logger Signals are buffered inside a drive with a fast sample interval. Can be triggered 
and uploaded to the monitor window to be analyzed.

Demo/Offline In Demo mode you can only view the default parameter values and settings in 
a pre-configured file. The FSO configuration file can be edited only in demo 
mode (for offline configuration).
In Offline mode you can set/view the saved parameter files offline. 
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DriveAP Adaptive Programming of a drive. Functionality of a drive can be modified by 
adding some IEC 61131 -based blocks. Adaptive Programming can be done 
also with an Assistant control panel.
Note: Adaptive Programming is not available with all drives.

EDS Electronic Data Sheet. EDS files are simple text files used by network 
configuration tools to identify products and describe the properties of these 
products and to commission them on a network.

Event logger Can consist of faults, alarms and events. Only faults stop the drive. Latest 
faults and alElectronic Data Sheetarms are also seen in parameter interface 
group 4, Warnings and Faults.

FENA-11 Ethernet adapter module for ABB drives.

LOC/REM LOC denotes local control of the drive, either with an Assistant control panel or 
the Drive composer PC tool. REM means that the drive is remotely controlled 
by the fieldbus master PLC or by I/O connections.

Lock/Unlock parameter Parameter can be locked by a drive. You can only view the parameter values, 
but cannot modify them. 

Macro script User-written sequence of macro statements for reading and writing 
parameters/signals. Filename extension for macro scripts is *.p.

Monitoring You can set parameters or signals to the monitor window. Values are collected 
with the sampling interval and drawn to a window.

NLS support National Language Support, the user interface (UI) of Drive composer can be 
easily modified by editing language files found in the LANG folder of the Drive 
composer PC tool. 

Online/Offline Online = PC tool is connected with the drive. Offline = PC tool is not connected 
with the drive. In the Offline mode it is possible to open parameter files, save 
monitored data etc.

OPC server OPC DA server interface for Drive composer pro that allows other programs, 
such as Control Builder Pro (Advanced drive programming), to communicate 
with the drive.

Refresh the parameter Parameter values are updated when a group is opened. You can set 
parameters to the Auto-update mode or refresh the value manually. Signals are 
always updated automatically. Signals are bolded in the parameter list.

Report You can use report templates for energy savings, commissioning and 
maintenance. Templates can be modified.

Restore You can restore the drive. You can select the parameters to be restored during 
the restore operation. For example, motor identification run results can be 
restored or deleted during the restore operation. Can be used for cloning 
drives.

Save parameters Visible parameters of a parameter window or custom parameter window are 
saved to a file. Filename extension for saved parameters is *.dcparamsbak.
Note: Some values are not editable in the Offline mode.

Support diagnostics 
package

You can collect all data from a drive for troubleshooting purposes by clicking a 
button in Drive composer or on an Assistant control panel.

Workspace Workspace consists of the user interface status, such as parameters shown in 
the custom parameter window(s) and their status. You can save the current 
workspace status to a file and restore it later. Custom parameter windows with 
their contents and the monitor window contents (signals selected, scalings, 
colors) are saved to a workspace. You can set one default workspace. 
Filename extension for the workspace is *.dcxml.

Term or abbreviation Explanation
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2
Overview of Drive composer

Contents of this chapter
This chapter briefly lists the main features of the Drive composer software and instructs 
how and where it can be run, and how to get help and additional information.

Drive composer
Drive composer is a 32-bit Windows application for commissioning and maintaining ABB 
common architecture drives.

The full version is called Drive composer pro and the limited version is called Drive 
composer entry. 

Both versions include a demo mode that allows testing the user interface functionality, edit 
parameter files offline (pro) or open and analyze the saved or monitored files without 
connecting to a physical drive. The safety configuration file can be edited (with sanity 
check) only in demo mode for offline configuration. 
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Compatibility
Drive composer is a software tool for all ABB common architecture drives and devices. 
The main products are, for example, ACS880, DCS880, ACS580, ACH580, ACQ580, 
ACS560 and ACS480 drive families.

Drive composer entry offers the basic features that are common to all compatible drives. 
The connections from Drive composer entry to the drive with an Assistant control panel is 
also common for all compatible drives and devices.

Drive composer pro offers a variety of features and software modules whose availability is 
dependent on the connected drives and option modules. Drive composer pro recognizes 
the connected drive based on the type code and firmware version and then adapts the 
availability of features accordingly. For non-recognized, but compatible drives, the same 
common basic features are available than with Drive composer entry.

Drive composer pro has a limited support (parameter editing and monitoring) for ACS800. 
It requires DriveWindow 2.40 installation on the same PC.

Highlights
With Drive composer, it is possible to:
• control a drive: start, stop, direction, speed/torque/frequency reference
• monitor the operation and status of a drive
• view and adjust drive parameters
• monitor signals in numerical and graphical (trending) format
• work simultaneously with multiple drives like master and follower drives (pro)
• display control diagrams of a drive for parameter setting and diagnostic purposes (pro)
• create user-specific workspaces by customizing parameter windows
• configure the optional FSO-12, FSO-21 safety functions module (pro)
• handle workspaces
• create and execute macro scripts (pro)
• use Ethernet-based fieldbus adapter modules for PC tool communication (one-wire 

solution, Profinet, Ethernet IP) (pro) or a drive-embedded Ethernet port
• use the USB port of an Assistant control panel for an USB connection
• use an OPC-based commissioning and maintenance tool (pro).
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Features
Feature Drive composer 

entry
Drive composer 

pro

Parameters can be modified Yes Yes

Parameters can be searched Yes Yes

Parameters changed by the user (or automatically updated) have 
an orange background

Yes Yes

Parameters can be saved to a file Yes Yes

Parameters can be copied/downloaded to a drive Yes Yes

Parameter windows can be customized Yes Yes

Parameters can be printed Yes Yes

Parameters can be edited offline No Yes

Parameters can be compared between parameter lists or drives No Yes

Data for the support service can be collected by clicking the 
Support package icon

Yes Yes

As a simple monitoring method for basic purposes, up to 8 signals 
can be monitored

Yes Yes

Monitored data can be saved to a hard drive of a PC Yes Yes

Monitored data can be exported to a PC by using the tab separated 
file

Yes Yes

For a professional analysis of a single drive or multidrive, 
maximum 26 signals can be monitored

No Yes

Contents of an event logger (faults, warnings) can be viewed Partly Yes

Contents of the System info (drive serial number, modules, 
versions, SW etc.) can be viewed

Yes Yes

Backup/Restore can be used for restoring or cloning a drive Yes Yes

Network Backup can be used for taking a backup of an entire 
multidrive with single click.

No Yes

PC can be used to analyze the data logged in a drive by a data 
logger

No Yes

Macro scripts can be created and executed No Yes

Safety settings can be configured to a safety functions module 
(FSO)

No Yes

Point-to-point USB can be connected through a panel port Yes Yes

Network drives can be connected via Ethernet or with a panelbus No Yes

Control diagrams of a drive can be used for parameter setting and 
diagnostic purposes

No Yes

User interface is available in different languages Yes Yes

Create and edit Adaptive Programs No Yes

Support of Virtual drive smart components No Yes
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Hardware and software requirements
Drive composer hardware

• USB type A (PC) type mini B (panel) cable for connecting Drive composer entry/pro 
through the USB port of the control panel to a drive (max 3 m)
Note: We recommend ferrite core cables.

• Ethernet cable RJ45 if the connection is made through the FENA-11 or embedded 
Ethernet

Computer hardware
• IBM compatible PC
• Pentium 2000 MHz or a faster processor (Dual-core or better recommended)
• 1GB RAM
• 1024 x 600 display resolution with 256 colors
• At least 150 MB free hard disk space
• CD drive
• One free USB port or Ethernet port

Software
• Operating system Windows XP, Vista, Windows 7 or Windows 8 (32- or 64-bit 

operating system)
•  Microsoft.NET Framework 4.5.1 is required for Windows 7/Windows 8 or 4.0.3 for 

Windows XP.

Note: Update the latest version of Microsoft.NET Framework on your PC.
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3
Installation and uninstallation of 
Drive composer

Contents of this chapter
This chapter describes how to install and uninstall the Drive composer software. 

Determining the current Drive composer version
To know the version of the Drive composer PC tool, select About the product in the Help 
menu. The About the product dialog box displays the Drive composer version.

Figure 1. About the product dialog box
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Installing Drive composer with the installer
It is recommended to uninstall all previous versions of Drive composer before installing a 
new version. Close all applications before starting the installation.

1. Run the setup.exe file from the folder where you unzipped the Drive composer files.

2. With Windows 7, right-click on the setup.exe file and select Run as administrator.

Figure 2. Installing Drive composer: Run as administrator

3. In the Drive composer pro - InstallShield Wizard, click Next >.

Figure 3. Installing Drive composer: Setup wizard window
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4. Choose the destination folder and click Next >.

Figure 4. Installing Drive composer: Destination folder window

5. Click Install to start the installation.

Figure 5. Installing Drive composer: Install window
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If Drive composer installation is complete, click Finish. Now the Drive composer is ready 
for use.

Figure 6.  Installing Drive composer: Installation completed window



Installation and uninstallation of Drive composer   25

Uninstalling Drive composer with the installer
1. In the Control panel → Programs → Program and features window, select the 

installed Drive composer pro program and click Uninstall.

Figure 7. Uninstalling Drive composer

2. Click Yes to uninstall Drive composer pro application.

Figure 8. Uninstalling Drive composer: Confirm removal of Drive composer
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Registration
Drive composer pro includes a license and requires registration. During the first launch of 
the software, preferably the registration can be made online. You can also make offline 
registration in case of no Internet connection is available on the PC where Drive composer 
is installed.

You can also run Drive composer pro for 30 days in fully functional evaluation mode.

Online registration
During the first launch of Drive composer pro, a prompt for license key appears.

Figure 9. Online registration: Product activation

Fill in the license key and click Activate. You are forwarded to registration form. Fill the 
details accurately and proceed with registration.

Offline registration
To make offline registration, contact your local ABB representatives and provide the 
following details.
• Name of the registrar
• E-mail address
• Company name
• Field of industry (optional)

Note: Offline registration is only possible during 30 days evaluation period.

After manual registration process by ABB support personnel, you will be provided a 
license file that you can use for offline registration. Go to Help → Import licence file, fill in 
the license key and use the license file provided.

Figure 10. Offline registration: Import licence file
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4
Connections

Contents of this chapter
This chapter describes how to make a USB connection or an Ethernet connection to an 
ABB drive with Drive composer.

Assistant control panel drivers
You can connect an ABB drive to an Assistant control panel (ACS-AP-x) through USB by 
installing the required USB device drivers. Drive composer installer installs the required 
drivers automatically, so no user actions are needed.

In case of any problems with automatic installer the USB drivers can be manually installed 
by downloading the tool from software tools website: 

http://new.abb.com/drives/software-tools/drive-composer

Follow the instructions provided with the drive package.
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Connecting to a drive with an Assistant control panel for 
the first time
To establish a connection between Drive composer and drive, connect a USB type A (PC) 
type mini B (panel) cable to the USB port of the computer and the USB port of the 
Assistant control panel (ACS-AP-x panel). The maximum length of the USB cable should 
be 3 m. If the drive is used without an Assistant control panel or with a Basic control panel, 
use separate USB/485 adapter to establish connection between Drive composer and 
drive.

1. Connect your PC to the Assistant control panel with a USB cable.

Figure 11. USB connection between Assistant control panel and PC
The following text appears on the Assistant control panel screen: “USB connected”.
Note: The Assistant control panel cannot be used when it is connected to a PC.

2. Launch Drive composer by double-clicking Drive composer entry/pro.exe.

3. Click Connect if you want to connect to the drive or click Demo if you want to choose 
the Offline mode. You can also select the dedicated connections to the drive: 

Figure 12. Connecting to a drive: Connect/Demo button

ABB drive
Assistant
control
panel

PC with 
Drive 

composer

USB cable
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• DDCS enabled (ACS800 only) - Connects to the drive through DDCS (fiber optic) 
communication. This option is applicable to ACS800 drive type only.

• USB/COM enabled - Connects to the drive through USB connection. Use this option 
only when you want to connect to the drive through serial connection, example, USB 
cable to ACS-AP-x panel.

• Ethernet enabled - Connects to the drive through Ethernet network.
• Virtual drive enabled - Connects to the Virtual drive smart component. This option is 

applicable only when you have Automation Builder installed in the PC.
• Comm settings - Opens another dialog where you can configure the connections in 

more detail other than the above three options.

Note: 
• The status LED starts flickering in the Assistant control panel indicates data 

transfer between drive and PC. The LED keeps blinking as long as there is a PC 
tool connected to the drive. The welcome dialog box is shown on the screen 
indicating that the application is being initialized.

• First time connection, parameter texts are loaded from the drive and this might 
take few minutes depending on the drive type.

Drive composer loads parameters and the following window displays.

Figure 13. Connecting to a drive: Parameters loaded
You have now an online connection to the drive. If you have a single drive and a point-
to-point connection, move to chapter Parameter window.

4. If you failed to make an online connection to the drive, go to View → Settings to 
check your COM settings and click View → Refresh (Ctrl + R) to reconnect Drive 
composer to the drive.
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Changing the language settings
1. To change the language settings of the Drive composer UI, go to View → Settings. 

Figure 14. Changing language settings: View → Settings

2. In the Settings window, choose the required language for the Drive composer UI.

Figure 15. Language settings
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• Drive composer default language to choose the default language of the menu or 
button text in Drive composer.

• Drive default language to choose the default language for parameters.

By changing language settings you can always use the same language when you connect 
Drive composer to the drive. 

3. After changing the language settings click View → Refresh (Ctrl + R) or restart the 
Drive composer application.

Note: Some elements might require application restart to update the selected language.
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Connecting to a drive via an Ethernet network
Ethernet network connection

There are ABB drives which have control boards with an embedded Ethernet port and 
ABB drives in which the Ethernet connection is made with the FENA-11 Ethernet adapter 
module. For the installation of the adapter module, see FENA-01/-11 Ethernet adapter 
module user’s manual (3AUA0000093568 [English]).

Note: The PC/Ethernet Switch firewall must be configured to allow a connection for Drive 
composer pro (port http 80 and UDP) or the firewall must be disabled. 

Creating an Ethernet network connection with Drive composer (pro)
1. Connect the FENA module to a drive.

2. Create a point-to-point connection from Assistant control panel or Drive composer to 
each drive.

3. If you use one adapter module with a drive, enable the FENA-11 by setting parameter 
50.01 FBA A enable to Enable and parameter 50.21 FBA A Timelevel sel to Fast (or 
Monitoring for Tool network only).

4. If you use two fieldbus adapters with the drive and the FENA-11 has been installed as 
FBA B, enable the FENA-11 by setting parameters 50.31 FBA B enable to Enable and 
50.51 FBA B Timelevel sel to Fast (or Monitoring for Tool network only).

5. Set a static IP address for each drive. See FENA-01/-11 Ethernet adapter module 
user’s manual (3AUA0000093568 [English]).

Figure 16. Ethernet connection: IP settings of the drive with Drive composer

6. Refresh the settings with parameter 51.27 FBA par refresh.

Note: Refreshing the Node setting will lose the communication to the drive. To re-establish 
the connection with the drive, select View → Refresh.

7. Name each drive to facilitate the recognition of drives when creating an Ethernet 
network connection.
If you use Drive composer, name the drives on the System info tab by typing the name 
to the Drive name field and clicking Set.

Figure 17. Ethernet connection: Naming a drive with Drive composer
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Note: The drive name changes after the view has been refreshed. The previous 
names in other existing workspaces are not affected.
If you use Assistant control panel, name the drives through the Setting menu of the 
panel.

8. Configure the TCP/IP address of your PC. In this example the TCP/IP address is 
192.168.0.1. For more information on configuring the TCP/IP address, see 
Configuring the TCP/IP address with Windows XP or Configuring the TCP/IP address 
with Windows 7.

Configuring the TCP/IP address with Windows XP

1. Go to Control panel → Network and Internet Connections → Network 
Connections.

2. In the Network Connections window, double-click the required connection.

Figure 18. Configuring TCP/IP address: Network Connections window
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3. Click the Properties button. The Local Area Connection Status dialog box appears.

Figure 19. Configuring TCP/IP address: Local Area Connection Status

4. Select Internet Protocol (TCP/IP) and click Properties.

Figure 20. Configuring TCP/IP address: Local Area Connection Properties
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5. Select Use the following IP address and type the IP address and the subnet mask.
Click OK.

Figure 21. Configuring TCP/IP address: Use IP address

TCP/IP address configuration is completed.
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Configuring the TCP/IP address with Windows 7
1. Go to Control Panel and click View network status and tasks.

Figure 22. Configuring TCP/IP address: Win 7 Control Panel

2. Click Change adapter settings on the left pane. A Network connections window 
displays.

Figure 23. Configuring TCP/IP address (Win 7): Adapter settings

3. Double-click Local Area Connection.

Figure 24. Configuring TCP/IP address (Win 7): Local Area Connection
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4. Click Properties.

Figure 25. Configuring TCP/IP address (Wind 7): Local Area Connection Status

5. Select Internet Protocol Version 4 (TCP/IPv4) and click Properties.

Figure 26. Configuring TCP/IP address (Win 7): Local Area Connection Properties
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6. Select Use the following IP address, type the IP address and subnet mask and click 
OK.

Figure 27. Configuring TCP/IP address (Win 7): Use IP address

7. Connect the RJ45 cable between the FENA module and PC. Alternatively, connect all 
drives and PC to the same Ethernet switch.
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8. Open command prompt (cmd.exe) and ping all the drives that you have configured.

Figure 28. Configuring TCP/IP address (Win 7): Ping drives

Note: You must open http port 80 of the firewall on your PC to enable Drive composer pro 
to communicate with drives.

9. Open Drive composer pro. In the Welcome window, make sure Ethernet enabled is 
checked. Click on Comm settings button.

Figure 29. Configuring TCP/IP address (Win 7): Ethernet enabled
The Drive Ethernet Configuration Tool window appears.
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10. Click Scan → Scan Network. Make sure Auto configuration mode is checked. 

Figure 30. Configuring TCP/IP address (Win 7): Communication settings
Drive composer scans all COM ports and Ethernet ports to find drives. 
If problems arise, see Ethernet tool network for ACS880 drives application guide 
(3AUA0000125635 [English]).
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Connecting network drives (pro)
Panel bus network connection

ABB drives with an ACS-AP-x panel can be daisy-chained through the control panel ports 
as a network either for a PC tool or a panel bus connection.

Note: Some ABB drives control boards (for example, ZCU-13) do not have any daisy-
chain connectors. For those drives, a panel bus connection can be created with FDPI-02 
option modules. See FDPI-02 diagnostics and panel interface user’s manual 
(3AUA0000113618 [English]) for more information.

Figure 31. Connecting network drives: Creating a panel bus

Creating a panel bus with Drive composer (pro)
1. Create a point-to-point connection from the Assistant control panel or Drive composer 

to each drive.

2. Set an independent node ID for each drive (with parameter 49.01 Node ID number).
The node ID must be between 1…32.

3. Refresh the settings (with parameter 49.06 Refresh settings).

Note: Refreshing the Node setting will lose the communication to the drive. To re-establish
the connection with the drive, select View → Refresh.

4. With parameter 49.05 Communication loss action, define how the drive reacts to a 
control panel (or PC tool) communication break by selecting No action.

Figure 32. Creating a panel bus: Panel port settings

5. Give a name for each drive to facilitate the recognition of drives when creating a panel 
bus connection.
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If you use Drive composer, name the drives on the System info tab by entering the 
name to the Drive name field and clicking Set.

Figure 33. Creating a panel bus: Naming a drive
Note: The drive name changes after the view has been refreshed. The previous 
names in other existing workspaces are not affected.
If you use Assistant control panel, name the drives through the Setting menu of the 
panel.

6. Remove all panels connected to drives.

7. To daisy-chain the drives connect a standard RJ45 (straight CAT5) cable to the left-
hand side connector of the Assistant control panel in the first drive (the left-hand side 
drive in figure Connecting network drives: Creating a panel bus on page 41).
Note: Heavy-industry type RJ45 male connectors do not fit into the drive side female 
RJ45 slot

8. Connect a standard RJ45 (straight CAT5) cable from the right-hand side connector of 
the Assistant control panel in the first drive to the left-hand side connector of the 
Assistant control panel in the second drive.

9. Continue chaining the rest of the drives as described above.

10. If there is a long distance between the first and last drive in a panel bus, set the 
resistor to the ON position in the last node.

Connecting to the panel bus with Drive composer (pro)
1. Connect a USB cable between the Assistant control panel and your PC.

2. Double-click Drive composer pro.exe to launch Drive composer.
The status LED starts flickering on the Assistant control panel.

3. Drive composer starts scanning all selected networks and loads the connected drives.

4. Make sure you see all drives in the Drive list.
Notes: 
• If you see a missing drive, close the PC tool and try again. If you still do not see all 

drives, check Group 49 Panel port communication for the settings of the missing 
drives.

• Drive composer does not automatically open any parameter window or other 
object.

5. Select and click a drive from the Drive list.
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Connection sharing (pro)
Select the option Share connection with Automation Builder to enable the 
simultaneous connection to the same drive from both applications.

Figure 34. Connection sharing: Settings
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5

Main user interface components

Contents of this chapter
This chapter describes the user interface (UI) components and how to use them.

Overview
The user interface consists of the following parts:

1. Title bar

2. Menu bar

3. Drive control panel

4. Drive list

5. Status panel (including the output view of the selected drive)

6. Working area for parameter windows, event logger, control diagrams, assistants etc.

The working area can be used either with tabs or floating windows. The figure below 
shows the user interface with tabbed windows.

The size of the drive list can be adjusted to the left/right. Similarly, the size of the working 
area can be adjusted by dragging the white separating line up/down. Most of the windows 
that are not maximized can be resized by dragging any corner. Scroll bars appear on the 
side or bottom of a window if it is possible to scroll the content.
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Figure 35. Overview of the user interface

1
2

3

4

5

6



Main user interface components   47

Title bar
The title bar is located at the top of the main window. It consists of the following parts:

• System menu icon 
• Application name and version number (Drive composer entry/pro)
• Name of the workspace (if there is an active workspace)
• Minimize button which has the same function as Minimize in the System menu
• Maximize/Restore Down button (the name depends on the status of the maximized 

window) which has the same function as Maximize or Restore in the System menu
• Close button which has the same function as Close in the System menu.

Note: When you close the application, system prompts to confirm. Click Ok to close 
the application.

To reduce the main window to the task bar or a sub-window to the bottom of the window 
area, click the Minimize button or go to system menu and click Minimize.

To enlarge the window to fill the available space, click the Maximize button or go to system 
menu and click Maximize.

To restore the window to the size and position it had before it was maximized, click 
Restore Down button or go to system menu and click Restore.

You can also maximize or restore the window by double-clicking the title bar.

To move a window, drag the title bar. To move a dialog box, drag its title bar. If you have 
maximized or minimized a window, you cannot move it by dragging the title bar.

To end your Drive composer session, click the Close button. Before closing down, Drive 
composer may:
• warn you about releasing control of the drive if the drive is controlled locally by Drive 

composer
• prompt you to save the workspace with unsaved changes
• remind you to save your monitor data
• remind you of unfinished printing.

Note: If you disconnect cable from the drive before closing Drive composer there might be 
long delay in operation.



48   Main user interface components

Note: To disable the function prompting you to save the workspace with unsaved changes, 
go to View → Settings.

Figure 36. Save workspace on exit function

You can close Drive composer by
• double-clicking the System menu icon
• selecting Close in the System menu
• selecting Exit in the File menu
• pressing the shortcut key Alt+F4.
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System menu
You can open the System menu by

• left or right-clicking the System menu icon 
• pressing the shortcut key Alt+space bar
• right-clicking within the non-button area of the title bar.

The System menu contains the following commands:
• Restore – same function as the Maximize/Restore Down button in the title bar when 

the window is maximized. The Restore command restores the window to its size and 
position which it had before it was maximized.

• Move – the function can be performed also by dragging the title bar. After selecting the 
Move command from the System menu, it is possible to move the window with the 
arrow keys. To stop moving the window, press Enter. To cancel the move, press Esc.

• Size – the function can be performed also by dragging any of the sides or corners of 
the window. After selecting the Size command, it is possible to resize the window with 
the arrow keys. To stop resizing the window, press Enter. To cancel resizing, press 
Esc.

• Minimize – same function as the Minimize button in the title bar. The Minimize 
command reduces the window to the task bar or to the bottom of the window area.

• Maximize – same function as the Maximize button in the title bar when the window 
has not been maximized. The Maximize command enlarges the window to fill the 
available space.

• Close – same function as the Close button in the title bar. The Close command ends 
the Drive composer session.
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Menu bar
The menu bar is located below the title bar. It contains the following drop-down main 
menus:
• File
• Edit
• View
• Tools (pro)
• Help.

To execute a command from a menu, click its name on the menu. You can also use the 
arrow keys to navigate between the menus. To execute a highlighted command, press 
ENTER. To close a menu, press the ESC key. You can also use the shortcut keys to 
execute the commands.

File menu
The File menu is always located in the menu bar.

Figure 37. File menu

The File menu contains the following commands:
• New.. opens a window where you can select a custom parameter set window. The 

keyboard shortcut for the custom parameter set command is Ctrl+N.

Figure 38. File menu: Custom parameter set
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• Open.. opens a new dialog.

Figure 39. File menu: Open command
• Open the latest saved workspace opens the latest saved workspace. The 

keyboard shortcut for the open latest saved workspace command is Ctrl+L.
• Open Workspace opens a new window where you can select the saved 

workspace to be opened. The keyboard shortcut for the Workspace command is 
Ctrl+O.

• Monitor file opens a window to open the parameter file for monitoring.
• Parameter file opens a new window where you can select the saved parameter 

file to be opened. The keyboard shortcut for the Parameter file command is Alt+P.
• Custom parameter file opens a new window where you can open the saved 

custom parameter file. The keyboard shortcut for the Custom parameter file 
command is Alt+W.

• Open support package opens a new window where you can select the saved 
support package file to be opened.

• Save workspace saves the active workspace to a file. The keyboard shortcut for 
the Save workspace command is Ctrl+S.

• Save workspace as default saves the active workspace to default workspace. 
The default workspace opens automatically when Drive composer is opened. The 
keyboard shortcut for the Save workspace as default command is Ctrl+D.

• Print menu prints the parameter screen.
• Print real-time monitor view (pro) prints the monitor screen.
• Exit ends the Drive composer session.
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Edit menu
The Edit menu is always located in the menu bar.

Figure 40. Edit menu

The menu contains the language commands with which you can select the language for 
the Drive composer user interface.

Note: Restart the Drive composer to see the language changes.
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View menu
The View menu is always located in the menu bar.

Figure 41. View menu

The View menu contains the following commands:
• Normal text font size for selecting the normal font size. The keyboard shortcut for 

Normal text font size is Ctrl+F6.
Note: The change in the font size does not affect the size of the monitor window font.

• Large text font size for selecting the larger font size. The keyboard shortcut for Large 
text font size is Ctrl+F7.

• The largest text font size for selecting the largest font size. The keyboard shortcut for 
the largest text font size is Ctrl+F8. The font sizes can also be changed with the 
following A-letter icons. 

Figure 42. View menu: A-letter icons for changing the font size
• Tabs for changing the working area to be viewed as tabs. The keyboard shortcut for 

Tabs is Alt+T.
Note: The monitor window cannot be tabbed.

• Floating windows for changing the working area in a separate window. The keyboard 
shortcut for Floating windows is Alt+F.
Note: The monitor window cannot be a floating window.

• Tile horizontally for changing floating windows to be tiled horizontally. The keyboard 
shortcut for Tile horizontally is Alt+H.

• Tile vertically for changing floating windows to vertical. The keyboard shortcut for Tile 
vertically is Alt+V.
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• Cascade for changing floating windows to cascade. The keyboard shortcut for 
Cascade is Alt+C. The cascaded windows can be resized and freely located in the 
working area.

• Settings for defining language, connection configuration, workspace settings, local 
control disable and temporary files location.

• Disconnect for disconnecting the drive composer with the drive.
• Refresh for creating a new connection to the drive (uploads parameter information 

from a single drive and creates a new connection with multidrives). The keyboard 
shortcut for Refresh is Ctrl+R.
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Tools menu (pro)
The Tools menu is located in the menu bar. The commands of the Tools menu vary 
between SW versions and drives.

Figure 43. Tools menu

The menu contains the following commands:
• Safety Configuration Report prints the safety functions configuration report with the 

FSO module installed.
• Backup network creates the backup of all connected drives in a PC tool network. The 

keyboard shortcut for Backup network is Ctrl+ B. See Creating a backup of a drive 
(page 138).

• Compare drive data compares the parameters of two drives or a parameter file and a 
drive or two parameter files. The keyboard shortcut for Compare drive data is Alt+C.

• PSL2 data logger uploads PSL2 data logger files from the drive flash memory to PC 
local hard drive. This option is applicable only in BCU-x2 control unit. See Using the 
PSL2 data logger (pro) (page 144).

• PSL2 Data Viewer opens and views contents of the uploaded PSL2 data logger files 
in the PC local hard drive. See Using the PSL2 data viewer (pro) (page 145).

• Localization Editor allows to read texts from drive, to make changes and to update 
texts to the drive. See Using the Localization editor (page 140).

• Drive Parameter Conversion Tool converts the parameters. See Using the Drive 
parameter conversion tool (pro) (page 141).

• EDS Export for creating the EDS files of a connected drive. The keyboard shortcut for 
EDS Export is Ctrl+I.

• Application symbols for showing the symbols exported from Control Builder Plus 
application for the drive. If the drive does not have Control Builder Plus, the application 
list remains empty. The keyboard shortcut for showing the application symbols is 
Ctrl+A.

• Macro for parameter value setting to multiple networked drives when custom window 
functionality is not sufficient. 
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Help menu
The Help menu is always located in the menu bar.

Figure 44. Help menu

The Help menu contains the following commands:
• Content or the F1 key opens the Drive composer user manual as a PDF file.
• Firmware manual or the F3 key opens the firmware manual of the connected drive 

type in a separate window as a PDF file. If you have selected a parameter or some 
other significant item when you click this command or press the F3 key, the 
appropriate chapter in the firmware manual is displayed.

• Make support package function creates a single file, that can be sent to local ABB 
support contact in case of any need for support.

• Import licence file (pro) function displays the Product activation window. Enter the 
activation key and click Activate.

• About the product opens a window displaying the program information, version 
number and copyright text.
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Drive control panel
The drive control panel is located below the menu bar. It has buttons for controlling a 
connected drive. It also shows the status of the drive.

Figure 45. Drive control panel

The drive control panel contains the following buttons and items:
• Name and node number of the currently controlled drive and an indication if it is 

running. See below for status icons explanations.
• Control button controls the selected drive with Drive composer or releasing the 

control of the drive.
• Reset fault button sends a reset command to the drive. If the fault is no longer active, 

the drive clears it.
• Start button starts the currently controlled drive. A motor connected to the drive starts 

rotating according to the set reference value.
• Stop button stops the rotation of the motor connected to the currently controlled drive.
• Coast stop button.
• Reference value field enables entering a new reference value. When you click the 

Reference field, a tooltip tells you max and min limits for the reference and current 
reference value.

• Reference field shows the reference used in the drive. The reverse direction is set 
manually with the - sign.

• Set button enforces the value in the reference value field to the currently controlled 
drive. The same command can be performed by pressing Enter.

• Active reference displays the reference value.
• Step configuration cycle button enables to modify Step type, Step value and Step 

duration with reference value. The available configuration is dependent on the 
connected drive.

• Step functionality activates the step cycle with the reference value.
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Drive list panel
The drive list panel shows all connected drives and open files. Drives are indicated with a 
motor icon (clockwise open circle arrow).

Figure 46. Drive list panel: Connected drives

A grey circle arrow indicates a stopped drive.

Figure 47. Drive list panel: Stopped drive

A green circle arrow indicates a running drive. 

Figure 48. Drive list panel: Running drive

A red circle with a white cross (x) indicates a faulty drive.

Figure 49. Drive list panel: Faulty drive

An orange background means that a drive that has an alarm.

Figure 50. Drive list panel: Drive with an alarm
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A red broken line (—/ /—) means that the connection to a drive has broken.

Figure 51. Drive list panel: Drive with a broken connection

The views for a drive – parameter window, data logger, event logger, system info, 
assistants (if such are available for the drive), control diagrams (if such are available for 
the drive) – can be seen by clicking with the primary mouse button and selecting the 
corresponding icons from the pop-up window.

You can open those views either as new tabs or floating windows. If an active window is 
associated with a drive or a file, the corresponding tree item is highlighted in the drive list.

Using the drive control panel for starting the drive
1. See the firmware manual of the drive for parameters you must set before starting.

2. Click the Control button.
The control box indicator changes to LOC.

3. Enter a reference value and press Enter or click the Set button.

4. Click Start.
The drive starts. The indicator box arrow changes to green.

Note: Limit settings in group 30 affect reference limits.
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Working area
Parameter windows, custom parameter windows, event logger, system info, control 
diagrams, assistants etc. are shown in the working area. The user interface is tabbed by 
default. You can change the order of tabs by dragging them. You can open tabs for a single 
drive or for multiple drives.

Figure 52. Working area: Tabbed user interface

The working area can be set to a floating window. For example, parameter window, event 
logger, system info etc. are shown as floating windows. The floating windows can be tiled 
vertically or horizontally or cascaded by using the commands in the View menu.

Figure 53. Working area: Floating windows
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6
Parameter window

Contents of this chapter
This chapter describes the parameter and custom parameter windows.

Parameter window
With Drive composer entry the parameter window is always opened when you make 
connection to a drive. With Drive composer pro the parameter window is opened by 
clicking on the selected drive in the drive list and selecting Parameters.

Figure 54. Parameter window: Open drive parameters

The parameter window view displays parameter groups, parameters and their values for 
the associated drive or a file. There can be several parameter windows in the working 
area. The headline of each parameter window shows which drive it belongs to. 
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Following are the command icons available in the parameter window.  

Icon Description

Expands/collapses parameter groups. When parameter groups are 
expanded, all parameter values are read once from the drive.

Saves parameters to a file. Saves visible parameters to a file. File 
extension is dcparams(bak).

Enables you to search parameter lists with a keyword. Search is 
activated/deactivated by clicking the Filter check box. When the Filter 
check box is unchecked all parameters are seen.
Note: If parameter groups have not been expanded, the first search takes 
about 30…60 seconds.

Allows you to select/deselect columns to be seen in a parameter window.

Parameters are updated only when a group is opened. With the Enable 
updating function it is possible to set all open and visible groups to be 
updated automatically. Parameters that have been set to be updated 
automatically have a yellow background.

Allows you to download parameters from a file to a drive. With a custom 
parameter window allows downloading offline values to a drive.

Enables you to change the window target, which is useful if you have 
Drive composer pro and you have to check certain parameters of another 
drive. Included only in custom parameter windows.

Provides you with a list of all user-changed parameters if you click the 
check box. These parameters have an orange background.

Allows you to add or remove one parameter or signal or several 
parameters or signals to/from a custom parameter window.
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Figure 55. Parameter window: Selected drive parameters
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The parameter window contains different types of parameters. Some of these types are 
identified by colors or bold fonts as shown in the table below:

The most common type is the regular parameter. Parameters are normally readable and 
writable. However, when the drive is running, some parameters may be write-protected.

Parameter names, values, units, default values and different user sets are shown in the 
parameter window. The number of user sets depends on the drive type.

The value of a parameter is read only once. If you want to update this value, right-click and 
select Refresh the parameter. You can set all visible parameters to update automatically 
by clicking the Enable updating button.

The values of signals cannot be modified. If signals are modified, you will get an error 
prompt for every signal. Signals are updated cyclically in the parameter window. 
Parameter signals are also updated frequently, but their values can be modified.

Navigating parameters and groups
Parameter values are updated if they are modified. A parameter value can be modified by 
double-clicking the parameter or by pressing Enter on a highlighted parameter. To update 
parameter group values, right-click the group name and select Refresh group 
parameters.

In special cases, hidden parameters and groups become available by modifying some 
parameter values, the View → Refresh command updates the whole parameter table. An 
example for such a group is group 51 FBA A Settings: When the adapter module has been 
enabled in group 50, the parameter names can be seen by selecting View → Refresh.

Note: The parameter window must be closed before refreshing and opened again after 
refreshing.

There are five alternative formats in which parameters are shown: default, binary, 
hexadecimal, integer and float format. To change the format of a parameter, right-click and 
select either Use default format, Use binary format, Use hexadecimal format, Use 
integer format or Use float format.
You can change the widths of the columns by dragging the vertical lines between the 
column headers.

Illustration Explanation

20.3      Ext1 In1 source                     D1 Normal parameters

1.1        Motor speed used               0.00 rpm Signals (bold)

10.21    RO status                             
Bit names of a parameter can be seen by double-
clicking on the parameter. New window opens.

11.6      DIO1 output source               P.10.1.1 Parameter value is set from another parameter, for 
example, parameter group 10, index 1, bit 1.

11.6      DIO1 output source               P.10.1.1 - Parameter value is an inverted bit of another 
parameter, group 10, index 1, bit 1.

20.1      Ext1 commands                    User has changed the value of a parameter (shown 
with an orange background).
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Double-click the value field box to see the bit names of certain binary parameters. For 
example, see the below parameter 10.1 DI status.

Figure 56. Navigating parameters and groups: Parametet bit names 

To reset a parameter, right-click it and select Reset to default.
Parameter values are read once when a group is opened. Independent parameters from 
different groups can be set to the Auto-update mode by right-clicking them and selecting 
Add to auto-update. The parameters that are updated automatically are seen with a 
yellow background as shown in the following figure.

Note: Signals are automatically updated cyclically
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Figure 57. Navigating parameters and groups: Parameters with yellow background

Parameters or signals can be sent to the monitor window by right-clicking them and 
selecting Send to monitor. Parameters can be copied to a custom parameter window by 
right-clicking them and selecting Copy. In addition, you can drag and drop parameters to a 
custom parameter window.
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Pointer parameters
One special type of a parameter is a pointer parameter. The value of a pointer parameter 
is read from the parameter it points to. Depending on the pointer parameter, value or bit 
pointer, its target can be another parameter or one of its bits. Some pointer parameters 
can be assigned Active (false) or Inactive (true).

In most cases, common settings are offered as a selection list. In those cases where the 
selection list does not offer the correct pointer, pointing can be done by selecting Other… 
from a selection list.

Figure 58. Pointer parameters: Constant value

Select a parameter from the list for a value pointer and then its bit from 0 to 31 for a bit 
pointer.

You can also enter a value manually by selecting the Edit manually check box. The value 
must follow form P.#.#.#, where the first # is the parameter group number, the second # is 
the parameter number and the third # is the bit number without leading zeros (for example 
P.2.1.2).

Active (false) or Inactive (true) are the constant values that can be entered manually.
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A bit pointer value can also be inverted by selecting the Invert value check box.

Figure 59. Pointer parameters: Inverting a bit pointer value

The inverted bit pointer value is shown with the minus sign at the end of the parameter.

Figure 60. Pointer parameters: Inverted bit pointer value with minus sign
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Setting fieldbus data in/out parameters
Process data transferred to and from the drive/PLC is set with parameter groups 52 and 
53. With an ACS880 drive it is possible to select the data type for each selected 
parameter/signal in these group.

1. Double-click FBA data in/out parameter and select Other.

Figure 61. Setting fieldbus data in/out parameters: Select data type
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2. Select the format in which the value is handled:16-bit, 32-bit or floating point format.

Figure 62. Setting fieldbus data in/out parameters: Select format
In the parameter window the selections are shown inside brackets: [16], [32] or [F].

Figure 63. Setting fieldbus data in/out parameters: Formats shown inside brackets

Note: The floating point or 32-bit value reserves 2 slots in the configuration. Consequently, 
if you try to select a value for parameter 52.04 as in the figure above, you get a Parwrite 
failed error message. The scalings of parameters/signals are found in ACS880 primary 
control program firmware manual (AUA0000085967 [English]).

Note: You should always check the parameter mapping from the manual of the used 
fieldbus protocol. Example, FENA-01/-11/-21 Ethernet adapter module user's manual 
(3AUA0000093568 [English]) or FPBA-01 PROFIBUS DP adapter module user's manual 
(3AFE68573271 [English]).
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Binary parameters
Binary parameters have a special meaning for each of their bits. These parameters are 
modified in a special Set binary parameter dialog. The value can be modified numerically 
in binary, hexadecimal or decimal format. 

You can modify the values in the bit by double-clicking the value field for each bit. Some 
bits are greyed out and disable to edit.

Another way to modify a bit is to type the bit value directly to the New value [bin] / [hex] / 
[dec] field.

Signal values, which are in binary format, can be viewed in a similar dialog.

Figure 64. Binary parameter editor
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Search for groups and parameters
You can search the names of parameters and groups inside the parameter window. The 
search result is a list of all parameters matching the search text criteria. For example, all 
torque-related parameters can be found by entering search criteria “torque” in the Enter 
keyword field and clicking the Filter check box. To uncheck the Filter box, click it again.

Figure 65. Search groups and parameters: example

Note: The first search takes about 30…60 seconds, because Drive composer goes 
through the whole parameter structure. The next searches are fast. All searches are in 
memory of the PC as long as Drive composer is on.
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Custom parameter window
In Drive composer it is possible to customize parameter windows. This means that 
parameters/signals can be dragged and dropped or copied from the main parameter 
window or from other custom parameter windows. You can rename custom parameter 
windows.

For example, you can collect all the typical parameters used in a quick start-up to one 
window. You can create separate windows for separate functions (for example, references, 
limits, ACS880 I/O). Custom parameter windows open automatically when a connection to 
a drive is made because they are saved with the workplace. Custom parameter windows 
can also be opened separately.

Parameter values can be changed in custom parameter windows. Custom parameter 
windows can be used both in tabbed and floating windows environments.

Separate custom parameter windows can be also saved to a file by selecting Save 
parameters to file. The changed values in the Offline value column are saved as well. 
Therefore the contents of a custom parameter window can be used for the 
parameterization of another drive. You can send the saved custom parameter windows to 
other users and they can open them with their Drive composer to see parameters that you 
want them to check or download to a drive.

Note: When a custom parameter window is saved, the actual drive values of the Value 
column are copied to the Offline value column. During loading the values in the Offline 
value column are shown in comparison with the current actual values. When you open the 
file containing the saved custom parameter window you can copy the values of the Offline 
value column to another drive by clicking the Download to device button.

Figure 66. Custom parameter window: Download to device button

In a network of drives, you can create a custom parameter window including 
parameters/signals selected from different drives. To have a view where all parameters are 
from one drive, click the Change drive button and select the drive.

To see the value of a parameter/signal used in another drive, right-click the 
parameter/signal and select Change drive.

Figure 67. Custom parameter window: Change drive 
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Adding parameters to a custom parameter window
The following example shows how to:
• create a new custom parameter window
• add parameters to a custom parameter window
• modify the Offline value column in the custom parameter window
• copy/download parameters to a drive.

1. Click File → New → Custom parameter set.

Figure 68. Custom parameter set

2. Name the custom parameter window.

Figure 69. Custom parameter set: Name of window

3. Click Add button to add parameters/signals to the new custom parameter window or 
copy paste from other parameter window.

Figure 70. Custom parameter set: Add parameter



Parameter window   75

4. For example, select minimum and maximum speed values from the parameter group 
30 Limits and click Apply changes.

Figure 71. Custom parameter set: Add minimum and maximum values

5. The Value column shows the values of connected drive. Enter values in the Offline 
value column to be same as Value column or you can type new values.

Figure 72. Custom parameter set: Change Offline values
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6. Click on Save parameters to file icon to save the custom parameter window.

Figure 73. Custom parameter set: Save parameter to file

Drive composer saves to file the values in the Offline value column. If the Offline value 
column was empty, then values in the Values column is saved.

7. When connecting the next drive open the created custom parameter window by 
clicking File → Open → Custom parameter file.
You can now see the online values of the new drive.
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8. Copy the offline parameter values to a new drive by clicking on Download to device 
icon.

Figure 74. Custom parameter set: Copy offline parameter values to a new drive
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Working with offline files
Types of offline files

There are two types of offline files containing parameter information.
• Parameter file is an offline file containing all parameter values.
• Support package is an offline file package that contains a collection of drive 

information, including all parameter values. You can open a support package file 
using Drive composer pro. For further information on support package, see 
chapter Diagnostics on page 103.

Saving parameters to a parameter file
To save parameters to a file, proceed as follows:

1. Connect to a drive and open parameter window.

2. In the parameter window, click Save parameters to file icon.

Figure 75. Save parameters to file 

3. Select a folder, enter a name for the dcparamsbak file and click Save.

Figure 76. Save parameters to file: Save the dcparamsbak file
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Opening a parameter file (entry)
To open a parameter file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File → Open → Parameter file.

3. Parameter window displays.

Opening an offline file containing parameter values (pro)
To open a file and view the parameter values offline, proceed as follows:

1. Connect to a drive.

2. Go to File → Open → Parameter file / Open Support package.

3. New item appears under File drives.

4. Select Parameters to open parameter window.

Figure 77. Opening an offline parameter file

Figure 78. Opening an offline parameter file from support package

Downloading parameter values to a drive
Note: The operation do not perform full restore. Only visible parameters and ID run results 
are copied to a drive when the download command is used. Also, drive type and software 
version are not checked when downloading parameter values from an offline file to a drive. 
For further information on Restore function, see chapter Other functions on page 137. 

To download offline parameter values to a drive, proceed as follows:

1. Open an offline parameter window.

2. If you have multiple drives connected online, click Change drive to select a drive you 
want to download the parameters.

Figure 79. Downloading parameter values: Change drive
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3. Download the parameter values to a drive by clicking the Download to device icon.

Figure 80. Downloading parameter values: Download to device icon

4. If you get a message indicating that the upload of parameter values is going on, click 
OK.

     You will get a report of the operation at the end of the restore operation.

5. Check the parameters that are failed during the restore operation.

Comparing drive data (pro)
Note: Both versions of Drive composer have Not at default function for listing user-
changed parameters. The Compare drive data function compares parameter values.

With Drive composer pro you can compare parameters between
• two drives
• two parameter files
• drive and parameter file.

1. Go to Tools → Compare drive data (Alt+C).

Figure 81. Comparing drive parameters
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2. In a PC tool network, select drives from Drive A and Drive B drop-down menus.

3. To open a parameter file for comparison, click Open.

4. To see the parameter list without differences, deactivate Show differences check 
box.

5. Click Start compare.
Note: The operation may take some time to compare two different parameter 
structures.
The following figure shows an example of the result.

Figure 82. Comparing drive parameters: Result of comparison

6. To export the result to a text (*.txt) file, click the Export.

Note: Click the >> << buttons to copy parameter values from Drive A to Drive B. 
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7
Monitor window

Contents of this chapter
This chapter describes the monitor window and its use.

Monitor window
In Drive composer you can monitor the operation of connected drives. In the online mode, 
the monitor window shows signal values in graphical or numerical format. The monitor 
data can be saved to a file for later use.

With Drive composer entry you can monitor up to 8 signals.

With Drive composer pro you can monitor up to 26 signals. If Drive composer pro is used 
with an ACS880 drive, it is possible to monitor 1 signal per 1-ms time interval.

The monitor window is always a tabbed window, in other words, there is only one monitor 
window available.

User-made monitoring settings (selected signals, y-scalings for signals, pen colors, 
number of grids etc.) are saved by default. In other words, when you open the tool, there 
are always the latest settings available.
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Resizing the monitor window
When you start Drive composer the monitor window is in the minimized position and you 
have to lift it in the following way before you can start monitoring.
• You can resize the monitor window by clicking the title bar with the primary mouse 

button and dragging it upwards.

Figure 83. Resizing monitor window
• You can resize the monitor window with the Minimize, Maximize and Split monitor 

buttons included in the Monitor menu bar.
• You can lift the monitor window by clicking the arrow buttons in the title bar.
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Adding parameters/signals for monitoring
There are two ways to add parameters/signals to the monitor window:
• Right-click a parameter/signal in the parameter window and select Send to monitor.

Figure 84. Monitor window: Send to monitor command
• Click the Add signal icon on the configurations and control area in the monitor 

window.

Figure 85. Monitor window: Configuration and control area icons
Select parameters from the Drive parameters list by double-clicking them or select a 
parameter and click Add button. You can add maximum of 26 parameters in Drive 
Composer pro and 8 parameters in Drive Composer entry.
Note: With Drive composer pro you can select signals/parameters from many different 
drives. Change the drive from the Drive list as shown in the following figure.
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Note: In the PC tool network via Ethernet or with a panelbus, it is recommend that you 
select Disable polling to enable the best sampling result for monitoring. The status of 
the drive(s) cannot be read before you have unselected Disable polling.

 

Figure 86. Monitor window: Drive list
The selected signals appear in the legend area.

To change the scalings of the y-axis of selected parameters/signals, click the Min or Max 
column in the legend area.

Active signals can be changed from the pull-down menu on the left side of the graph area.

All the other signal scalings are performed on the right side of the legend area. The right 
side y-scalings can be hidden by removing the check mark from the Y-scale column check 
box.

Figure 87. Monitor window: Changing pen color and style in the legend area

You can change the color and thickness of the pen only after you have minimized, that is 
hidden the legend area with the Arrow button on the left (see the figure above).

To change the scalings of the y-axis for selected parameters/signals, click the Min or Max 
column in the legend area.
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Monitor window components
The monitor window consists of the following parts:
• Configuration and control settings
• Graph area
• Y-axis
• X-axis
• Legend area
• Limit, color settings.
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Configuration and control settings
Icon Description

Opens the saved monitored file to the graph area, which can be done only after 
monitoring has been stopped. File extension is *.dcemon or *.dcpmon.
Note: If you have an online connection and want to start a new monitoring session 
after viewing opened monitored data, you can click the Monitor configuration icon.

Saves the accumulated monitor data to a monitored data file. File extension is 
*.dcemon for the entry version and *.dcpmon for the pro version.

Chart configuration can be used to set the colors for grids, number of grids, 
background color, color of alarm pen etc.

Opens the Monitor settings window where you can modify the monitor settings and 
the select the sample interval time for monitoring. You can also set the method for 
starting and/or stopping monitoring (by hand/time). You have to select the HD where 
the saved data is stored.
Note: The monitored data is saved cyclically to the selected file.
Created monitoring configuration can be saved and restored from Monitor settings 
window.

Allows you to create an arithmetic signal for monitoring by using two signals used in 
monitoring. Available operations are ADD, SUB, MUL and DIV.
Note: Remember to save settings in a workspace.

Opens a dialog where you can add or remove one signal or several signals from the 
monitor configuration.
Note: You can use the Add signal function only when monitoring has been stopped.

Shows the signal values in text format. Only the values seen in graph area are 
included in the numeric signal value list.

Copies the monitoring graph to a clipboard.

Scales the y-axis automatically.
Note: Zooming is not possible in the Autoscaling mode.

Resets both x- and y-axis zooming to original 100%.

You can export the monitored data in csv format to a PC. Exported data can analyzed 
with other tools. Use the Tab key for delimiting the columns.File extension is *.dcexp.

Aligns signals.

Selects or changes the drive.

Zooms in the x- and/or y-axis up to 1000%.
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Monitor controls
Icon Description

Starts recording data in the selected drives and displaying it on the screen.

Pauses monitoring on the screen but monitoring continues on the background. When 
you click the Pause icon again, all values are seen and monitoring continues 
normally.

Stops recording data in the selected drives. The graph or numerical values remain on 
the screen. The graph can be saved for later purposes.
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Active signal
The Active signal area consists of functions that can be done with the selected active 
signal. The signal can be changed from the pull-down menu. 

Figure 88. Monitor window: Active signal area

The main functions are the following:

Figure 89. Monitor window: Measuring points for active signal

Icon Description

Allows you to see the measuring points of the active signal. See figure Monitor 
window: Measuring points for active signal.
Note: This functionality works only if you have zoomed in enough in the graph area, 
that is, if the length of the x-axis is short enough.

Allows you to see the numeric values of the measuring points for the active signal. 
See figure Monitor window: Measuring points for active signal.
Note: This functionality works only if you have zoomed in enough in the graph area.

Searches to the left. The following search conditions can be selected from the 
pull-down menu: Above, Below or Either. See figure Monitor window: Search 
functionality.

Searches to the right. The following search conditions can be selected from the 
pull-down menu: Above, Below or Either. See figure Monitor window: Search 
functionality.
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Figure 90. Monitor window: Search functionality

Zooming
To enlarge the graph and take a closer look at the details, follow these steps:

1. To set the starting corner for the enlargement, place the mouse cursor in the graph 
area and press down the primary mouse button.

2. Drag to the opposite desired corner, and release the button.
The part of the graph that was inside the selection rectangle zooms out to fill the graph 
area.

3. To reset the zoom tool, click the Reset zoom icon.

You can also use the zooming tool by selecting independent values from x and y pull-down 
menus.

Note: Monitoring is paused during zooming. To continue monitoring, click the Reset zoom 
icon shown in the figure below.

Figure 91. Monitor window: Zoom tool

Panning
The graph can be panned by dragging the graph with the right mouse button pressed 
down.
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Legend area functions
The legend area shows selected signals. You can perform the following actions in the 
legend area:
• Change the color of the pen, thickness and style of the pen by minimizing the legend 

area and setting the values of each signal. See figure Monitor window: Legend area 
functions.

• Make signals visible or invisible by clicking the check box in the Visible column.
• Set a bit mask for monitoring. When you double-click the value in the Mask column, a 

new window opens allowing you to select bits for monitoring.
• Make Y-scalings visible or invisible by clicking the check box in the Y-scale column.
• Set values for y-axis scaling. You can modify the minimum and maximum values by 

clicking them and entering a new value. Press Enter to enforce the new value or press 
Esc to restore the value.
Note: If you do not see immediate changes in the graph area, check that autoscaling 
is not enabled.

• Set alarm limits for monitored signals. The color of a signal changes when the limit in 
the Alarm low or Alarm high column is reached. The color and style for the pen are 
selected from Chart settings.

• See the double cursor tool, y1 and y2 values and y2—y1 and x2—x1 differences.

Figure 92. Monitor window: Legend area functions

Graph area functions
The monitor window and data logger window have similar graph area facilities for 
displaying signal values. Their usage is described here. Before Drive composer starts 
monitoring online, the OnLine monitor text is seen in the graph area. When monitor files 
are viewed, the DataFile Viewer text is seen in the monitor window.

The graph area shows the selected signal values with different colors. The x-axis 
represents Time and can be set from 1 to 120s. You can change the values in online 
monitoring mode. Scalings of the y-axis are changed in the legend area.

For data logger files, an orange arrow-head on the x-axis indicates where triggering has 
occurred. Data can be combined from several files to one graph.
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Double cursor tool
With the cursor tool, you can see the exact values of the signals at two positions in the 
graph area. You can move the position of cursors by clicking the primary mouse button 
down on the red cursor tool icon and moving it. While the mouse button is pressed down, 
you can move the cursor line to the left and right.

The time stamp of the cursor tool is shown in the header of the cursor tool. This is shown 
for the active signal. The time stamp changes if active signal is changed. The values for y1 
and y2 are shown in the legend area. Signal value differences are shown in the column 
y2—y1. The time difference for x2—x1 is also shown in the figure below.

Figure 93. Monitor window: Double cursor tool
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8
Workspace handling

Contents of this chapter
This chapter describes the workspace functionality.

Overview
Workspace consists of the user interface status, such as parameter windows and custom 
parameter windows.

The current workspace status can be saved to a file and restored later.

Note: You cannot save/restore the following status data:
• drive control status
• If a drive has been controlled locally with Drive composer when the workspace is 

saved, the workspace is saved without the change in the drive control status.
• content, status and zooming levels of a stopped, paused or running monitor.

Note: Do not edit a workspace or graph file. The workspace (.dcxml) and monitored data 
(.dcmon) files can contain binary data. For example, if the default workspace file is 
corrupted, Drive composer does not open. If Drive composer does not open, delete your 
default (.dcxml) file from the PC and open Drive composer again.
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Creating a workspace and using it as a default workspace
1. Make a connection to a drive.

2. Resize the monitor window to half a screen.

3. Create a new custom parameter window by clicking File → New.. → Custom 
parameter set and name it “Own limit window”.

Figure 94. Creating workspace: Custom parameter set

4. In the File menu, click Save workspace to save the workspace.

5. Create another custom parameter window and name it “Own reference window”.

6. Select floating windows by clicking View → Floating windows.

7. Enter keyword “Limit” in the Enter keyword field of the main parameter window.

8. Select parameters in the main parameter window and drag and drop or copy them to 
custom parameter window Limit.

9. Clear the search result and enter keyword “ref” in the Enter keyword field.

10. Select parameters in the main parameter window and drag and drop or copy them to 
custom parameter window Own reference window.

11. Close the main parameter window.

12. Click Event logger icon in the drive list on the left.
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13. Click File → Save workspace and name it “OwnWorkspaceFor_ACS880”. See figure 
In the File menu, click Save workspace to save the workspace..

Figure 95. Creating workspace: Name your workspace

14. Close the connection to the drive and make a new connection.



98   Workspace handling

15. Click File → Open.. → Open workspace and open the workplace that you have 
saved.
 

Figure 96. Creating workspace: Open workspace command
The workspace is ready to use for commissioning and maintaining drives.
The workspace can also be saved as a default workspace which opens automatically 
when Drive composer is started.
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9
Event logger

Contents of this chapter
This chapter describes the event logger view and its use.

Event logger view
The event logger view displays the contents of an event logger of a connected drive. The 
contents of an event logger can be faults (stopping the drive), alarms or events. See the 
figure below.

With some drives there can be more data of a fault in the monitor window.

Note: Fault logger data can also be seen from other faults than the latest active faults.
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Figure 97. Event logger view

The event logger always relates to a single drive and resides in its window.

The Icon column shows the following alarm and fault icons:
• Red circle with a white cross (x) means that the drive has a fault.
• Yellow triangle with an exclamation mark means that the drive has an alarm.
• Grey circle or triangle means that the fault or alarm has disappeared from the drive.

The time stamp for faults, alarms and events comes from the drive.

Faults, alarms and events can be sorted by clicking the header of the Fault column.
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Fault data logger
The Fault data icon in the Event logger view shows that the drive has fault data that can 
be seen with a monitor component. The icon is visible only if the drive sports the 
functionality.

Figure 98. Fault data icon

When you click the icon, the following message appears: “Please wait. Loading fault data 
appears”. When the message box disappears, the data has been loaded.

Figure 99. Fault data logger in the monitor window

Save the fault data.

Note: To continue the normal monitoring, click the Monitor configuration icon in the 
Monitor controls box.
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10
Diagnostics

Contents of this chapter
This chapter describes how to troubleshoot a drive with the Support package button of 
Drive composer and a Datalogger included in the drive.

Support package
Support package is an offline package file that contains, for example, full parameter 
backup, system information, and event logger contents. The main purpose is to collect 
troubleshooting data and send it to the support personnel for analysis.

Creating a support package
By clicking the Support package button, you can create and save a support package file.

Figure 100. Support package button



104   Diagnostics

Opening a support package (pro)
You can open Support package file in Drive composer pro by selecting File → Open → 
Open support package, a new File drive appears. There is similar menu available with 
online drives.

For further information on each module, see section System info on page 105, chapters 
Parameter window on page 61 and Event logger on page 99.
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Drive application programming license
The drive application programming license N8010 is required for downloading and 
executing the program code on the ACS880 drive. In DriveComposerPro, select System 
info tab. Check if the appropriate license is loaded to the drive. If the required license code 
is not available, contact ABB representative.

Figure 101. System info command

System info
The System info tab provides basic information about the drive and its options, for 
example, drive type code and firmware version.

Figure 102. System info

You can also set the time for the drive and name the drive.
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Datalogger (pro)
ABB drives have Datalogger(s) that can record data from various signals of a drive even if 
the drive is not connected to a PC. A Datalogger is operated with the Datalogger view.

Figure 103. Datalogger configuration

The data collecting can be stopped with a specific stop command or automatically when a 
triggering condition is true in the drive. After data collection stops you can read and study 
the data in Drive composer pro.
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The Datalogger view resembles the monitor window. Normally the Datalogger view 
provides data from a single drive.

Figure 104. Datalogger view
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Datalogger settings
The Datalogger settings window contains the following functions:
• Datalogger commands
• Datalogger content configuration
• Datalogger trigger configuration

Datalogger commands

Datalogger content configuration
With the Datalogger content configuration you can determine which Datalogger of a drive 
is used.

Figure 105. Datalogger content configuration

• Logger determines which logger settings are modified. A drive has user logger(s) and 
factory logger(s). Factory logger settings cannot be modified.

Button Description

Start button records data in the current logger of the drive until Datalogger is triggered 
or stopped.

Stop button ends recording immediately without any post trigger recording.

Trigger button triggers the associated logger in the drive. Trigger Datalogger is 
displayed in Datalogger status with trigger code 15.

Upload button moves data from the drive to PC and draws it to the monitor window. 
Datalogger replaces any previous data in monitor window.

Apply button applies monitored signal and Datalogger sampling settings.
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• Sampling interval determines in microseconds how often the logger reads samples 
of the signal values. The time level shows the available lengths of the internal cycle 
time of the drive. Sample interval is formed from multiplier (1-65535) and time level 
selection.

• Post trigger count specifies how many samples are stored after the triggering 
condition occurs when the value is smaller than Datalogger total space count. The 
Datalogger total space count depends on drive type, selected signal types and total 
signal count. If the post trigger count value is bigger than Datalogger total space count, 
the triggering point is not visible anymore in the Datalogger.

• Sampling time shows the minimum sampling time with a selected number of signals 
and a selected sample interval.

• Logger signals panel shows a list of the signals selected to record. You can 
add/remove a signal by clicking the Add signal icon.

To add parameters to the logger, proceed as follows:

1. In the Datalogger screen, click  to add parameters.

2. Select a parameter in the Drive parameters list and double-click or click Add. The 
parameter is added to Selected parameters.

Figure 106. Parameter window

Note: The maximum number of signals that a logger can record at one time depends on 
the drive. Add button is disabled when maximum number of parameters are reached. 

3. To remove the parameter from Selected parameters, select the desired parameter and 
click Remove.

4. Click Apply changes after making the changes.
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Datalogger trigger configuration
Datalogger has four triggers that can be configured to stop the Datalogger. After 
Datalogger has triggered, the Datalogger samples post trigger amount of new samples.

Figure 107. Datalogger trigger configuration
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Adding a trigger
1. To modify the conditions of a trigger, select the trigger from the Trigger drop-down 

menu.
Trigger 1 is normally used for user logger 1, Trigger 2 for user logger 2 etc.

2. Choose the type for the triggering condition from the Type drop-down menu.
Following are the alternatives (however, not all of them are available at all times):
• Bit mask stops according to the bit mask of the selected signal.
• Disabled can temporarily disable a trigger condition.
• Falling edge level stops according to the selected signal, triggering level and 

hysteresis values.
• Fault stops when the drive reports a fault.
• Event stops when the drive reports an event.
• Rising edge level stops according to the selected signal, triggering level and 

hysteresis values.
• Warning stops when the drive reports a warning.

3. If you use Rising edge level or Falling edge level as the type for the triggering 
condition, see Using the level triggers.

4. Click Apply.

Using the level triggers
When condition Rising edge level is used, the function wakes up when the actual value of 
the triggering signal is below the triggering level - hysteresis. Similarly, when condition 
Falling edge level is used, the function wakes up when the actual value of the triggering 
signal is above the triggering level + hysteresis.

Using bit mask trigger

Bit mask trigger reads signal value and masks out user selected bits with given mask. 
Masking is done by using a logical AND operation. Masked value is compared to user 
given bit values selection. When masked value and bit values match, Datalogger is 
triggered.

Rising edge Triggering signal is below the triggering level when the Datalogger is started:
Triggering occurs when the signal goes above the triggering level.
Triggering signal is above the triggering level when the Datalogger is started:
Triggering occurs when the signal goes above the triggering level, but before that the signal 
must go below the triggering level - hysteresis.

Falling edge Triggering signal is above the triggering level when the Datalogger is started:
Triggering occurs when the signal goes below the triggering level.
Triggering signal is below the triggering level when the Datalogger is started:
Triggering occurs when the signal goes below the triggering level, but before that the signal 
must go above the triggering level + hysteresis.
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Uploading triggered or stopped Datalogger data
1. In the Datalogger view select a logger from the Logger drop-down menu.

If the logger status is stopped or triggered, data can be uploaded.

2. Click Upload to upload data to the monitor window.
Note: If you want to continue normal monitoring after using the Datalogger, click 
Monitor configuration icon and select a sampling interval for monitoring.

Figure 108. Continue monitoring after using the Datalogger

3. Click Add signal icon to add signals for monitoring.

Figure 109. Uploaded Datalogger data
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Amplitude logger (pro)
ABB drives have an amplitude loggers that can record data from various signals of a drive. 
The results of an amplitude logger 1 (current) are displayed by the following curve. Each 
parameter represents an amplitude range and shows what portion of the samples fall 
within that range.

Note: Dataloggers or amplitude loggers are not available for all ABB drives.

Figure 110. Amplitude logger
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Macro (pro)
ABB drives have Macro functionality that can automatize a task or sequence of tasks. 
Macros are used for parameter value setting to multiple networked drives when custom 
window functionality is not sufficient. Macros may also be used for tasks which require 
logical or conditional parameterization of a drive.
• In the main menu, click Tools and select Macro.

Figure 111. Macro command

A Macro screen is displayed.

Figure 112. Macro 
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Macro commands
Macro language

Macro language is based on PAWN. For general programming guidelines, refer to PAWN 
manual. 

Note: Some PAWN features are disabled for security reasons, such as file operations and 
other external IO functions.

Simple example
Macro tries to read parameter 1.1 value from each target in 100 network channels.

main()

{

    for(new i = 0; i < 100; i++)

    {

        //note the channels are indexed instead of nodes

        // this should be modified according network topology

        //change target

        Target(i+1,1)

        new targetName[100]

        //get target name

        TargetName (targetName)

        //read parameter 1.1 value

        new Float:val0101 = ParRead(1,1);

        //output to console

        printf "%s(%d,%d): %f\n", targetName, 1, 1, val0101 ;

    }

}
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Additional macro commands

Target
Changes the target of the macro commands after target command is issued.

Target name
Command reads the current target name as string.

ParWrite

Command writes parameter value to current target.

Note: This function cannot be used to read or write pointer or bit pointer type parameter 
values.

ParRead
Command reads the parameter value to current target.

Note: This function cannot be used to read or write pointer or bit pointer type parameter 
values.

Syntax Returns Example

Target (Channel, node) 0 if success, 1 if failed Target (1, 10)

Syntax Returns Example

TargetName (string) 0 if success, 1 if failed //reserve name string
new name[100]

if(TargetName(name)==0)

{

  printf "target name is %s\n" name
}

Syntax Returns Exmaple

ParWrite (group, index, value) 0 if success, 1 if failed //write value 1 to group 12 
index 16

ParWrite (12, 16, 1)

Syntax Returns Example

ParRead (group, index) Parameter value or 0 if 
failed

On error, the error 
message is shown in 
the log

//Read value of the parameter 
in group 10 index 5

new Float:val = Par-
Read(10,5);

printf "value of (%d,%d): 
%f\n", 10, 5, val105;
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Wait
Command delays the macro execution for given time in milliseconds.

EndMacro
Command ends the macro execution.

GotoMacro
Command changes the macro execution. Currently running macro execution is 
terminated.

MessageBox
Command shows message box with ok button.

Syntax Returns Example

Wait (milliseconds) 0 in all cases //wait 0.1 seconds

Wait(100)

Syntax Returns Example

EndMacro() 0 in all cases //End execution

EndMacro()

Syntax Returns Example

GotoMacro(string) 0 in all cases //Change execution to macro jeejee

new macrofilename[100]

macrofilename = “jeejee.p”

GotoMacro(macrofilename)

Syntax Returns Example

MessageBox (string) 0 in all cases //show messagebox

new message[100]

message = "dingalongdangdong"

MessageBox (message)
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11
Control diagrams (pro)

Contents this chapter
This chapter describes the use of control diagrams helping to understand the behavior of a 
drive.

Control diagrams
Control diagrams provide a graphical presentation of, for example, the control chain of a 
drive, the speed and torque control chains and the logic of Start and Stop functions. With 
these diagrams it is possible to see parameter values related to certain functions. 
Diagrams also illustrate the position of switches according to parameter values, which 
helps to understand how the drive logic works. The values of parameters can be changed 
via control diagrams. A control diagram consists of two levels. The top level shows an 
overview of the diagrams and connections between them.

Note: Control Diagrams are drive-specific and they are not available for all drive types.

Note: When you connect a drive for the first time, it takes sometime to upload control 
diagrams from the drive. If Control Diagrams are not found in the drive, Drive composer 
asks to upload diagrams from the local source (PC).
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Launch Control Diagrams by clicking a drive and selecting Diagrams.

Figure 113. Control diagrams: Selecting from the drive tree

The top level of a diagram consists of several diagrams. To open one part of a specific 
diagram, click the top of a box. The figures below show an example of a top level control 
diagram and a lower level control diagram.

Figure 114. Control diagrams: Top level 
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.

Figure 115. Control diagrams: Lower level 

To navigate back to the top level of a Control Diagram, click the Diagrams top icon. To 
navigate through the reference chain, click the buttons circled in the figure above.

To zoom the control diagrams, use the zooming tool in the top left-hand corner of a Control 
Diagram.

Figure 116. Control diagrams: Zooming tool
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12
FSO configuration (pro)

Contents of this chapter
This chapter contains the configuration procedure of FSO-12 and FSO-21 safety functions 
with Drive composer pro and provides an example of how to configure these optional FSO 
safety functions modules.

Configuring FSO-12 and FSO-21
The safety configuration of FSO-12 and FSO-21 safety functions module is available only 
in Drive composer pro, DCPT-01 (code: 3AUA0000108087). 

Note: 
• Only trained persons are allowed to configure the safety functions. 
• Stop the drive before configuring the safety functions modules. You cannot 

download/upload the configuration file to/from safety functions module or change 
the password when the drive is modulating.

• You need a password to copy the configuration to the safety functions and also to 
validate the safety parameter settings. 

• You can open a dcsafety file in Demo mode of Drive composer pro.

For detailed information about FSO-12 and FSO-21, see the respective safety functions 
module user’s manual:

• FSO-12 safety functions module user’s manual (3AXD50000015612 [English]).
• FSO-21 safety functions module user’s manual (3AXD50000015614) [English]).



124   FSO configuration (pro)

Hardware connection
The hardware connection is common for both FSO-12 and FSO-21 safety functions 
module. For instructions on the hardware connections, see FSO-12 safety functions 
module user’s manual (3AXD50000015612 [English])/ FSO-21 safety functions module 
user’s manual (3AXD50000015614 [English]). 

The following configuration description assumes that all hardware-related connections are 
made properly and the ID run procedure of the drive is completed.

Setting the safety functions with Drive composer pro

WARNING! The motor must be stopped. Safety configuration file can be edited (and 
sanity checked) in demo mode for offline configuration. Edit and save the file to PC 
without connecting to the drive/FSO.

1. Power up the drive. Make sure that the motor is not running. 
See Using the drive control panel for starting the drive on page 59.

2. Right-click on drive and select Safety settings. 

Figure 117. FSO configuration: Selecting safety settings with FSO module
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In online mode with FSO installed, the safety configuration already available in the drive is 
displayed (see figure below). In offline mode the view is always empty before opening the 
safety file.

You can switch between Graphical view and Parameter view. See Figure 118.FSO 
configuration: Graphical view and Figure 119.FSO configuration: Parameter view.

Figure 118. FSO configuration: Graphical view

Figure 119. FSO configuration: Parameter view
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3. Click Read settings from drive.
Note: When you upload the safety settings from FSO module to PC tool, the FSO 
goes into Configuration state and indicates a fault. You can exit the Configuration state 
by rebooting the FSO module if you do not want to download the settings but want to 
keep the existing setting. 
The Fault FSO general fault: 7A8B appears on the drive.

Figure 120. FSO configuration: FSO general fault due to configuration state

4. Type the password (8 numbers). The factory default password is “12345678”.

Figure 121. FSO configuration: Enter password
Note: You can change password by clicking Change password (see figure FSO 
configuration: Parameter view). Make sure the drive is not modulating. The password 
must contain 4…8 digits. Do not forget the new password; otherwise you have to do a 
factory reset to the FSO which clears the configuration and resets the parameters to 
the factory defaults.

5. Configure the safety parameters. Set the following safety function parameters:
• General parameters: Check that the motor parameters are correct.
• I/O: Check that I/O parameters are set according to the installation (wiring) plan. 

Remove diagnostic pulsing from any unused I/O. The test pulses are off by 
default. Check possible safety relays and cascade connections.

• Safety functions: Check all safety settings. You must at least check and set the 
STO and SSE related settings, regardless of whichever FSO safety functions you 
use. The FSO activates the STO and SSE functions (also in internal fault 
situations). The FSO uses the STO and SSE functions for making the system 
safe. All other functions are used only for monitoring the drive.

Notes: 
• Graphical view cannot be used for setting safe IO, cascade function or for SBC 

function (see Figure 118.FSO configuration: Graphical view). Instead use the 
Parameter view (see Figure 119.FSO configuration: Parameter view).

• Parameter groups (200, 91 and 92) that include common parameters to drive and 
FSO are referred with group numbers and index numbers.

• Group names like FSOGEN, STO and so on have only index numbers (see Figure 
125.FSO configuration: Edit parameters). 

For examples of configuration settings and list of group names, see FSO safety 
functions module User’s manual.
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6. In graphical view, double-click a function or the General settings tile to activate the 
safety function and open the general settings.
Note: You can view the filtered tiles view with the Filter functions by setups. Click 
one of these filtering options to filter other tiles away from the view.

Figure 122. FSO configuration: Filter function in graphical view

7. In the opened tile view, configure the function or general settings group by editing all 
necessary parameters. 

Figure 123. FSO configuration: Configure function or general settings group
After editing is completed, click Done to close or to stop editing. Click Reset if you 
want to reset to default. 
Note: In Graphical view the SAR settings are combined with safety function 
parameters. Using the reset option for parameters that are used crosswise (e.g. SAR1 
is used with SS1 and SLS functions) resets the particular settings for both functions. 
The function works the same in parameter view in which the parameters are in 
separate groups.
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8. In the Graphical view, enable/disable the function or general settings group using the 
slider switch. 

Figure 124. FSO configuration: Enable/disable function

9. In Parameter view, double-click on the value field and change all necessary 
configuration settings to match the safety configuration.

Figure 125. FSO configuration: Edit parameters

10. Test your safety configuration when the motor is running.

Slider switch enabled

Slider switch disabled
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11. Right-click on drive and select Parameters to check the values in parameter 
group 200. 
You can also validate the safety function parameters using the signal monitoring 
feature. See the instructions for Adding parameters/signals for monitoring. It is 
possible to check the ramp times and the status of bit changes in the time domain. 

Figure 126. FSO configuration: Parameter group 200

12. Check the values in online mode while testing the safety functions.
If there are unexpected values, right-click the parameter and select Refresh the 
parameter.
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13. After testing save the FSO configuration to PC. In Parameter view, click Save to file.

Figure 127. FSO configuration: Saving the safety settings
The file is saved as dcsafety format and the File written successfully dialog appears. 
Click Ok.

14. Click Apply settings to drive. 

15. Enter the password to apply the settings to the drive and click Ok.
The following Validate dialog appears. Click Yes.

Figure 128. FSO configuration: Validate dialog
Note: If you do not want to download the changes in safety parameters, you can boot 
FSO without downloading to FSO using Reboot FSO (see figure FSO configuration: 
Saving the safety settings).

16. Click Ok to close the dialogs.

Figure 129. FSO configuration: Safety configuration ok message
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Printing the safety functions configuration report (Online)
With the FSO module installed, you can print the online safety functions configuration 
report. 

1. From the Safety settings view, click Print report.

Figure 130. Safety configuration report: Print Report

2. Select a print template and click Continue.

Figure 131. Safety configuration report: Select print template

3. Fill in the Drive and FSO version information. Click Next.

Figure 132. Safety configuration report: Drive and FSO information
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The next screen(s) contain different aspects of safety configuration such as configured 
safety functions, commissioning checklist, and so on. 

The List of configured safety functions and acknowledged methods appears. Click Next.

Figure 133. Safety configuration report: List of configured safety functions 

In the FSO commissioning checklist, click on the check boxes to mark configurations are 
ok. Click Next.

Figure 134. Safety configuration report: FSO commissioning check list
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In the FSO changes/repair details, type the required details and click Next.

Figure 135. Safety configuration report: FSO changes/repair

4. In the final screen fill in the required details and click Print preview. 

Figure 136. Safety configuration report: Print preview 
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5. Select the required printer settings and click Print.

Figure 137. Safety configuration report: Printer settings

The configuration and commissioning report is printed based on the selected printer 
settings.
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Printing the safety functions configuration report (Offline)
To print a FSO safety functions configuration report in the Offline mode, you must have a 
saved safety file. See section Setting the safety functions with Drive composer pro (page 
124).

1. Click Tools → Safety Configuration Report.

Figure 138. Print safety configuration report: Tools menu

2. Select the saved file to print and click Continue.

Figure 139. Print safety configuration report: Select print template 

Continue from step 3 in section Printing the safety functions configuration report (Online), 
page 131. 
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13
Other functions

Contents of this chapter
This chapter describes common functions that are not associated with any view or window. 

Related topics:

• Creating a backup of a drive
• Restoring a drive
• Using the Localization editor
• Using the Drive parameter conversion tool (pro)
• Using the PSL2 data logger (pro)
• Using the PSL2 data viewer (pro)
• Adaptive programming
• Locking user interface
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Creating a backup of a drive
1. Click Backup/restore.

Figure 140. Backup/restore command

2. Select the file location for the backup and give a name for the backup file.

Figure 141. Backup/restore: select backup file location

3. Click Backup to start the backup process.
The backup process takes a few minutes.

You can also create a backup in the drive parameter view. 

1. Click the Save parameters to file icon.

Figure 142. Create backup in drive parameter view
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2. Select the file location for the backup and give a name for the backup file. Click Save.
The backup process takes a few minutes.

Restoring a drive
1. Click Backup/restore. See Figure 140.Backup/restore command.

2. Select the backup file to be restored to the drive.

Figure 143. Backup/restore: select restored backup file location

3. Click Restore.
All available components are restored from the backup file. All unavailable 
components are preserved in the drive.

4. To select a set of components/parameter settings to be restored to the drive, click 
Advanced restore.
The parameter values that are not written to the drive are listed in the restore report 
after the restore process. If there are grey items in the advanced list, the drive does 
not allow the item to restore.

Note: Advanced restore option is available only in Drive composer pro version.

You can also restore a backup in the drive parameter view when the parameter backup file 
is opened. Click Download to device icon.

Figure 144. Backup/restore: Restore in drive parameter view

All available components are restored from the backup file. All unavailable components 
are preserved in the drive.
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Using the Localization editor
You can manage user editable texts using the Localization editor. The function allows to 
read texts from drive, to make changes and to update texts to the drive.

Localization editor 
1. Select Tools → Localization Editor.

2. Select the drive to work with and click Ok.

The Localization editor is started and attached to the selected drive.

3. Read and make changes in the column Localized text. If you changed any text, click 
Apply.

Changes are written to device and Download finished successfully message appears.

4. Click Ok.
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Using the Drive parameter conversion tool (pro)
The parameter files of some ACS800/ACS600 ABB drive types commissioned and 
maintained with DriveWindow can be accessed with Drive composer via the Drive 
parameter conversion tool.

Note: Not all ACS800/ACS600 drives and software are supported.

1. Go to Tools → Drive parameter conversion tool.

Figure 145. Drive parameter conversion: Introduction
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2. Click Next and select the appropriate ACS800/ACS600 parameter file.

Figure 146. Drive parameter conversion: Browsing the ACS800/600 file

3. Select an empty ACx80 parameter file with default values. to do: You must create 
offline parameter file (of the destination drive family) to select here.

Figure 147. Drive parameter conversion: Browsing the ACSX80 parameter file
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4. Select name for the drive.

Figure 148. Drive parameter conversion: Save target
Note: Do not overwrite the empty file.

5. Click Next.
6. Answer Yes.

The Conversion report shows the parameters which are converted successfully and 
failed. Read the report carefully and fix the parameter values manually for which the 
conversion was not successful. 

Figure 149. Drive parameter conversion: Results 
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Using the PSL2 data logger (pro)
With BCU-x2 control unit, you can upload the PSL2 data logger files from the drive flash 
memory to PC local hard drive. The files contain real time data from the converter modules 
that help in fault tracing and analysis. 

Note: The files can be uploaded from drive to local computer only. You cannot read the 
contents or open the files. For any further assistance contact ABB customer support.

Uploading PSL2 data logger files
1. Go to Tools → PSL2 data logger. 

Figure 150. PSL2 Data logger screen

2. Using the right arrow button, place the PSU data logger file(s) that you want to upload 
in the right side box. 

3. In the Upload directory field, click  and select an upload folder in your PC local hard 
drive.

4. Click Upload...
The selected files are transfered to your local folder.
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Using the PSL2 data viewer (pro)
You can open and view contents of the uploaded PSL2 data logger files in the PC local 
hard drive. The files contain real time data from the converter modules that help in fault 
tracing and analysis. 

Viewing PSL2 data logger files
1. Go to Tools → PSL2 Data Viewer.

 PSL2 Data Viewer screen with PSL2 plotting tools appears. The plotting area is 
empty by default. See PSL2 Data Viewer instructions below to open and save the plot.

Figure 151. PSL2 Data viewer screen 

PSL2 Data Viewer instructions
The PSL2 plotting tools can be used to plot current and DC voltage using the uff or csv file. 
The table below describes how to use the plotting tools. Match the below instructions with 
the above PSL2 Data viewer screen.

Action Instruction

Opening uff or csv file. In the PSL2 Data Viewer window, click Open file icon and 
select the file to open. 

Saving the plot as csv file. Click Save to CSV icon. 

Saving the plot into different file formats. Click Save plot icon.

Selecting number of channels to view in 
the plot.

Select number of channels in the Number of visible channels 
drop-down list.

Viewing the selected channels. See in Selected channel drop-down list.
to do: is this a signal, or user selected list.

Aligning selected channels on the same 
axis 

Click on Use only one axis check box. 
Use this option to draw all selected channels on the same axis.

Open file...
Save to CSV...

Save plot...
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Setting minimum and maximum values 
of X-axis and Y-axis

Set required minimum and maximum values in the below fields 
and click on Update axis button.
• Y-axis min
• Y-axis max
• X-axis min
• X-axis max
Note: The min/max values of X-axis and Y-axis are equal in all 
visible plots.

Scaling X-axis and Y-axis automatically Click on Auto Scale button.
The largest and smallest values of data are scaled to Y-max Y-
min respectively.
Note: This action does not maintain the same scale in every 
parallel axis. 

Resetting min/max values of Y-axis to 
default values

Click on Default Scale button.
The graph is reset to the updated default values.

Updating calculation parameters to plot 
and recalculate the data

Set current and voltage values in Curr meas range [A] and 
DC meas range [V]. Click on Update button.

Viewing different plots Click on the tabs to view the required plot:
• Total Current and DC SI
• Sum currents %
• Phase X current diff %
• Sum current filtered %
• DC voltage diff %
• Module currents % and DC %

Inside the plot you can also do the 
following actions using keypad and 
mouse:

• use the right mouse button to move (pan) the plot up/down. 
The x-/ y-axis moves accordingly.

• use the mouse wheel to zoom the plot. Zooming multiple 
channels works best when the cursor is placed on an empty 
space i.e. top of upper axis, below the lower axis, or between 
the axis. 

• mark a rectangle with Ctrl+Right mouse button or Ctrl+Left 
mouse button to zoom the marked area

• hold the Left mouse button to view the plot tracker
• press 'A' key to reset the axis to set values
• press Ctrl+C to copy the bitmap of plot.

Action Instruction
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Adaptive programming
Adaptive programming is a feature to control the operation of a drive by parameters. Each 
parameter has a fixed set of choices or a setting range. The parameters make 
programming easy, but the choices are limited. You cannot customize the operation 
further. 

The Adaptive programming makes easy customizing possible without the need of a 
special programming tool or language. The program is built of function blocks.

Figure 152. Adaptive programming

For further information on Adaptive programming, refer Adaptive programming application 
guide in List of related manuals.
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Locking user interface
A user interface lock function is implemented to notify the device lock states, for example, 
when parameter system is locked or when file downloading is disabled. 

The function prevents you from:
• uploading device data, when file download function is disabled or when parameter 

system is locked
• creating device backup when the device is in protected state.

The function is implemented in DCPT-01 and DCET-01. See below sections that describe 
the lock states visible in different pages or views in the Drive composer.

Lock state in System info page
Go to the System info page by right clicking on the selected drive in the drive list and select 
System info. The different lock states displayed in the System info page are listed below. 

Lock state in parameter view
The user interface lock states are displayed in the following parameters view:
• Parameters view for online drive (see page 61)
• Custom parameter view (see page 73)
• Offline parameter view (see page 78)
• File parameter view (see page 61)

In the parameters view, the device lock states, i.e. Parameter system is locked or the File 
downloading is disabled, are accessible when you mouse hover the below two buttons:

•  Save parameters to file

•  Download to device 

The table below lists the different device states displayed in the parameters view. The 
example screens are from the custom parameter view. 

Device lock state Lock state messages

Initial state Set button is enabled.

Parameter system is 
locked

Set button is disabled. When you mouse hover the button, the tooltip “Parameters 
are locked on drive” appears.

File download is 
disabled

Set button is disabled. When you mouse hover the button, the tooltip “File 
downloading is disabled on drive” appears.
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Note: The two buttons listed above may be hidden and may not be visible in all views. 
When data in the view is loaded for different drives, the drive which is connected may not 
show the correct state of the buttons until you change the drive.

Lock state in Backup/Restore page
Go to the Backup/Restore page by right clicking on the selected drive in the drive list and 
select Backup/Restore. The different lock states displayed in the Backup/Restore page 
are listed below. 

Device lock state Lock state messages

Initial state Save parameters to file and Download to device buttons are enabled.

Parameter system is 
locked

Save parameters to file button is enabled. Download to device button is 
disabled. When you mouse hover the disabled button, the tooltip “Parameters are 
locked on drive” appears.

File download is 
disabled

Save parameters to file button is enabled. Download to device button is 
disabled. When you mouse hover the disabled button, the tooltip “File downloading 
is disabled on drive” appears.

Device lock state Lock state messages

Initial state All buttons, Backup, Restore and Advanced restore are enabled.

Note: Advanced restore button is available only in Drive composer pro, DCPT-01 
(code: 3AUA0000108087).

Parameter system is 
locked

Backup button is enabled. Restore and Advance restore buttons are disabled. 
When you mouse hover the disabled buttons, the tooltip “Parameters are locked on 
drive” appears.

Note: Advanced restore button is available only in Drive composer pro, DCPT-01 
(code: 3AUA0000108087).

Save parameters to file
Download to device
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Lock state in Safety settings page (pro)
Go to the Safety settings page by right clicking on the selected drive in the drive list and 
select Safety settings. The different lock states displayed in the Safety settings page are 
listed below. 

Note: The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

File download is 
disabled

Backup button is enabled. Restore and Advance restore buttons are disabled. 
When you mouse hover the disabled buttons, the tooltip “File downloading is 
disabled on drive” appears.

Note: Advanced restore is available only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

Device lock state Lock state messages

Initial state Buttons enabled: 
•  Read settings from drive 
•  Apply settings to drive
•  Print report
•  Reboot FSO
•  Change password.

Load from file is always enabled.
Save to file is enabled only when data is read.

Parameter system is 
locked

Buttons disabled:
•  Read settings from drive 
•  Apply settings to drive
•  Print report
•  Reboot FSO
•  Change password.

When you mouse hover the disabled buttons, the tooltip “Parameters are locked on 
drive” appears.
Load from file is always enabled.
Save to file is enabled only when data is read.

Device lock state Lock state messages
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Lock state in Localization editor (pro)
Go to Tools → Localization Editor. Select the drive to work with and click Ok. The 
Localization editor screen appears.

The different lock states displayed in the Localization editor are listed below. 

Note: The lock state messages are visible only in Drive composer pro, DCPT-01 (code: 
3AUA0000108087).

File download is 
disabled

Buttons disabled:
• Read settings from drive 
• Apply settings to drive
• Print report
• Reboot FSO
• Change password.

When you mouse hover the disabled buttons, the tooltip “File downloading is 
disabled on drive” appears.
Load from file is always enabled.
Save to file is enabled only when data is read.

Device lock state Lock state messages

Initial state Read button is always enabled.
Apply button is enabled only when text is changed in the Localized text column.

Parameter system is 
locked

Read button is always enabled.
If you changed text in the Localized text column, the changes are not effective 
and the Apply button is disabled. When you mouse hover the disabled button, 
the tooltip “Parameters are locked on drive” appears.

File download is 
disabled

Read button is always enabled.
If you changed text in the Localized text column, the changes are not effective 
and the Apply button is disabled. When you mouse hover the disabled button, 
the tooltip “File downloading is disabled on drive” appears. 

Device lock state Lock state messages
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Further information

Product and service inquiries
Address any inquiries about the product to your local ABB representative, quoting the type 
designation and serial number of the unit in question. A listing of ABB sales, support and 
service contacts can be found by navigating to www.abb.com/searchchannels.

Product training
For information on ABB product training, navigate to new.abb.com/service/training.

Providing feedback on ABB Drives manuals
Your comments on our manuals are welcome. Navigate to new.abb.com/drives/manuals-
feedback-form.

Document library on the Internet
You can find manuals and other product documents in PDF format on the Internet. Go to 
www.abb.com/drives/documents.
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